What’s Vulnerable › Vulnerabilities
CVE-2024-10002: Rover IDX <= 3.0.0.2905 - Authenticated (Subscriber+) Authentication Bypass to Administrator
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-22 · updated 2026-06-17
- Weakness: CWE-288
Description
The Rover IDX plugin for WordPress is vulnerable to Authentication Bypass in versions up to, and including, 3.0.0.2905. This is due to insufficient validation and capability check on the 'rover_idx_refresh_social_callback' function. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to log in to administrator. The vulnerability is partially patched in version 3.0.0.2905 and fully patched in version 3.0.0.2906.
Affected products
- stevemullen Rover IDX: before 3.0.0.2906 — fixed in 3.0.0.2906
How to fix
Upgrade to a fixed version: stevemullen Rover IDX 3.0.0.2906. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/rover-idx/tags/3.0.0.2903/admin/rover-panel-social.php#L153
- https://plugins.trac.wordpress.org/browser/rover-idx/tags/3.0.0.2903/rover-social-common.php#L148
- https://plugins.trac.wordpress.org/changeset/3173032/rover-idx/trunk/rover-social-common.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5cf6a9fb-3c3b-48ad-a39b-77a529b89901?source=cve
Get alerted when CVE-2024-10002 or the next vulnerability affects your stack