What’s Vulnerable › Vulnerabilities
CVE-2024-10020: Heateor Social Login WordPress <= 1.1.35 - Authentication Bypass via Disqus OAuth provider
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-06 · updated 2026-06-17
- Weakness: CWE-287
Description
The Heateor Social Login WordPress plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 1.1.35. This is due to insufficient verification on the user being returned by the social login token. This makes it possible for unauthenticated attackers to log in as any existing user on the site, if they have access to the email and the user does not have an already-existing account for the service returning the token. An attacker cannot authenticate as an administrator by default, but these accounts are also at risk if authentication for administrators has explicitly been allowed via the social login.
Affected products
- Heateor Social Login WordPress: before 1.1.36 — fixed in 1.1.36
How to fix
Upgrade to a fixed version: Heateor Social Login WordPress 1.1.36. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3177729/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6b1d212b-75fe-4285-9c22-62b040e5a36c?source=cve
Get alerted when CVE-2024-10020 or the next vulnerability affects your stack