What’s Vulnerable › Vulnerabilities

CVE-2024-10043: Incorrect Authorization in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions starting from 14.3 before 17.4.6, all versions starting from 17.5 before 17.5.4 all versions starting from 17.6 before 17.6.2, that allows group users to view confidential incident title through the Wiki History Diff feature, potentially leading to information disclosure.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.4.6, 17.5.4, 17.6.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-10043 or the next vulnerability affects your stack