What’s Vulnerable › Vulnerabilities
CVE-2024-10045: Transients Manager <= 2.0.6 - Cross-Site Request Forgery
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-23 · updated 2026-06-17
- Weakness: CWE-352
Description
The Transients Manager plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.0.6. This is due to missing or incorrect nonce validation on the process_actions function. This makes it possible for unauthenticated attackers to delete transients via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- smub Transients Manager: before 2.0.7 — fixed in 2.0.7
How to fix
Upgrade to a fixed version: smub Transients Manager 2.0.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/transients-manager/trunk/src/TransientsManager.php#L993
- https://plugins.trac.wordpress.org/changeset/3171619/transients-manager/trunk/src/TransientsManager.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/03b8b5a2-979d-42d0-86f5-48ee73162d22?source=cve
Get alerted when CVE-2024-10045 or the next vulnerability affects your stack