What’s Vulnerable › Vulnerabilities
CVE-2024-10054: Happyforms < 1.26.3 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Happyforms WordPress plugin before 1.26.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Happyforms: before 1.26.3 — fixed in 1.26.3
How to fix
Upgrade to a fixed version: Happyforms 1.26.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5a9fd64b-3207-4acb-92ff-1cca08c41ac9/
- https://wpscan.com/vulnerability/5a9fd64b-3207-4acb-92ff-1cca08c41ac9/
Get alerted when CVE-2024-10054 or the next vulnerability affects your stack