What’s Vulnerable › Vulnerabilities
CVE-2024-10055: Click to Chat – WP Support All-in-One Floating Widget <= 2.3.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via wpsaio_snapchat Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Click to Chat – WP Support All-in-One Floating Widget plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's wpsaio_snapchat shortcode in all versions up to, and including, 2.3.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. CVE-2024-49281 may be a duplicate of this issue.
Affected products
- Ninja Team Click to Chat – WP Support All-in-One Floating Widget: before 2.3.4 — fixed in 2.3.4
How to fix
Upgrade to a fixed version: Ninja Team Click to Chat – WP Support All-in-One Floating Widget 2.3.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3169768/
- https://wordpress.org/plugins/support-chat/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b4c13600-0791-4ade-9c28-f43f164aedae?source=cve
Get alerted when CVE-2024-10055 or the next vulnerability affects your stack