What’s Vulnerable › Vulnerabilities
CVE-2024-10076: Jetpack < 13.8, Boost < 3.4.8 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Jetpack WordPress plugin before 13.8, Jetpack Boost WordPress plugin before 3.4.8 use regexes in the Site Accelerator features when switching image URLs to their CDN counterpart. Unfortunately, some of them may match patterns it shouldn’t, ultimately making it possible for contributor and above users to perform Stored XSS attacks
Affected products
- Jetpack: before 13.8 — fixed in 13.8
- Jetpack Boost: before 3.4.8 — fixed in 3.4.8
How to fix
Upgrade to a fixed version: Jetpack 13.8; Jetpack Boost 3.4.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/15f278f6-0418-4c83-b925-b1a2d8c53e2f/
- https://wpscan.com/vulnerability/15f278f6-0418-4c83-b925-b1a2d8c53e2f/
Get alerted when CVE-2024-10076 or the next vulnerability affects your stack