What’s Vulnerable › Vulnerabilities
CVE-2024-10094
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-20 · updated 2026-06-17
- Weakness: CWE-94
Description
Pega Platform versions 6.x to Infinity 24.1.1 are affected by an issue with Improper Control of Generation of Code
Affected products
- Pega Systems Pega Infinity: from 6.0 before 8.1.9; from 8.2 before 8.2.8; from 8.3.0 before 8.3.6; from 8.4.0 before 8.4.6; from 8.5 before 8.5.6; from 8.6.0 before 8.6.6 — fixed in 23.1.4 , 24.1.2 , 8.1.9, 8.2.8, 8.3.6, 8.4.6
How to fix
Upgrade to a fixed version: Pega Systems Pega Infinity 23.1.4 , 24.1.2 , 8.1.9, 8.2.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10094 or the next vulnerability affects your stack