What’s Vulnerable › Vulnerabilities
CVE-2024-10104: Jobs for WordPress < 2.7.8 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Jobs for WordPress plugin before 2.7.8 does not sanitise and escape some of its Job settings, which could allow high privilege users such as contributor to perform Stored Cross-Site Scripting attacks
Affected products
- BlueGlass Jobs for WordPress: before 2.7.8 — fixed in 2.7.8
How to fix
Upgrade to a fixed version: BlueGlass Jobs for WordPress 2.7.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10104 or the next vulnerability affects your stack