What’s Vulnerable › Vulnerabilities
CVE-2024-10105: Jobs for WordPress < 2.7.11 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Job Postings WordPress plugin before 2.7.11 does not sanitise and escape some of its settings, which could allow high privilege users such as contributor to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- BlueGlass Jobs for WordPress: before 2.7.11 — fixed in 2.7.11
How to fix
Upgrade to a fixed version: BlueGlass Jobs for WordPress 2.7.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10105 or the next vulnerability affects your stack