What’s Vulnerable › Vulnerabilities
CVE-2024-10107: Giveaways and Contests by RafflePress < 1.12.17 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Giveaways and Contests by RafflePress WordPress plugin before 1.12.17 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Giveaways and Contests by RafflePress: before 1.12.17 — fixed in 1.12.17
How to fix
Upgrade to a fixed version: Giveaways and Contests by RafflePress 1.12.17. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/83590cad-6bfb-4dc7-b8fd-aecbc66f3c33/
- https://wpscan.com/vulnerability/83590cad-6bfb-4dc7-b8fd-aecbc66f3c33/
Get alerted when CVE-2024-10107 or the next vulnerability affects your stack