What’s Vulnerable › Vulnerabilities
CVE-2024-10109: Incorrect Authorization in mintplex-labs/anything-llm
- Severity: high (CVSS 8.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-863
Description
A vulnerability in the mintplex-labs/anything-llm repository, as of commit 5c40419, allows low privilege users to access the sensitive API endpoint "/api/system/custom-models". This access enables them to modify the model's API key and base path, leading to potential API key leakage and denial of service on chats.
Affected products
- Mintplexlabs Anythingllm: before 1.3.1 — fixed in 1.3.1
How to fix
Upgrade to a fixed version: Mintplexlabs Anythingllm 1.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/mintplex-labs/anything-llm/commit/8d302c3f670c582b09d47e96132c248101447a11
- https://huntr.com/bounties/ad3c9e76-679d-4775-b203-96947ff73551
Get alerted when CVE-2024-10109 or the next vulnerability affects your stack