What’s Vulnerable › Vulnerabilities
CVE-2024-10143: MB Custom Post Types & Custom Taxonomies < 2.7.7 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The MB Custom Post Types & Custom Taxonomies WordPress plugin before 2.7.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- MB Custom Post Types & Custom Taxonomies: before 2.7.7 — fixed in 2.7.7
How to fix
Upgrade to a fixed version: MB Custom Post Types & Custom Taxonomies 2.7.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b5fd7a3e-33e4-4c73-a581-881f063855b0/
- https://wpscan.com/vulnerability/b5fd7a3e-33e4-4c73-a581-881f063855b0/
Get alerted when CVE-2024-10143 or the next vulnerability affects your stack