What’s Vulnerable › Vulnerabilities
CVE-2024-10145: Hubbub Lite < 1.34.4 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Hubbub Lite WordPress plugin before 1.34.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Devpups Social Pug: before 1.34.4 — fixed in 1.34.4
How to fix
Upgrade to a fixed version: Devpups Social Pug 1.34.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b9e2381b-3ea0-48fa-bd9c-4181ddf36389/
- https://wpscan.com/vulnerability/b9e2381b-3ea0-48fa-bd9c-4181ddf36389/
Get alerted when CVE-2024-10145 or the next vulnerability affects your stack