What’s Vulnerable › Vulnerabilities
CVE-2024-10149: Social Slider Feed < 2.2.9 - Admin+ Stored XSS via Widgets
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Social Slider Feed WordPress plugin before 2.2.9 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Social Slider Feed: before 2.2.9 — fixed in 2.2.9
How to fix
Upgrade to a fixed version: Social Slider Feed 2.2.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1619dc4b-4e5e-4b82-820b-3c4e732db3ad/
- https://wpscan.com/vulnerability/1619dc4b-4e5e-4b82-820b-3c4e732db3ad/
Get alerted when CVE-2024-10149 or the next vulnerability affects your stack