What’s Vulnerable › Vulnerabilities
CVE-2024-10151: Auto iFrame < 2.0 - Contributor+ XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The Auto iFrame WordPress plugin before 2.0 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Auto iFrame: before 2.0 — fixed in 2.0
How to fix
Upgrade to a fixed version: Auto iFrame 2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10151 or the next vulnerability affects your stack