What’s Vulnerable › Vulnerabilities
CVE-2024-10168: Active Products Tables for WooCommerce. Use constructor to create tables <= 1.0.6.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via woot_button Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Active Products Tables for WooCommerce. Use constructor to create tables plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's woot_button shortcode in all versions up to, and including, 1.0.6.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- PluginUS Woot: before 1.0.6.5 — fixed in 1.0.6.5
How to fix
Upgrade to a fixed version: PluginUS Woot 1.0.6.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3182136/
- https://wordpress.org/plugins/profit-products-tables-for-woocommerce/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4a13b13e-72d3-43c9-b5ec-d499f3b22091?source=cve
Get alerted when CVE-2024-10168 or the next vulnerability affects your stack