What’s Vulnerable › Vulnerabilities
CVE-2024-10172: WPBakery Visual Composer WHMCS Elements <= 1.0.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via void_wbwhmcse_laouts_search Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The WPBakery Visual Composer WHMCS Elements plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's void_wbwhmcse_laouts_search shortcode in all versions up to, and including, 1.0.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- voidcoders WPBakery Visual Composer WHMCS Elements: before 1.0.4.1 — fixed in 1.0.4.1
How to fix
Upgrade to a fixed version: voidcoders WPBakery Visual Composer WHMCS Elements 1.0.4.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3204359%40void-visual-whmcs-element&new=3204359%40void-visual-whmcs-element&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/void-visual-whmcs-element/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cc4b52c6-1ac2-4f90-a776-c91232f5de34?source=cve
Get alerted when CVE-2024-10172 or the next vulnerability affects your stack