What’s Vulnerable › Vulnerabilities
CVE-2024-10181: Newsletters <= 4.9.9.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via newsletters_video Shortcode
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Newsletters plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's newsletters_video shortcode in all versions up to, and including, 4.9.9.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- contrid Newsletters: before 4.9.9.5 — fixed in 4.9.9.5
How to fix
Upgrade to a fixed version: contrid Newsletters 4.9.9.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3175816/
- https://wordpress.org/plugins/newsletters-lite/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/915c46f9-a342-4cc6-a726-2f1581a5d481?source=cve
Get alerted when CVE-2024-10181 or the next vulnerability affects your stack