What’s Vulnerable › Vulnerabilities
CVE-2024-10186: Event Post <= 5.9.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via events_cal Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Event post plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's events_cal shortcode in all versions up to, and including, 5.9.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Bastien Ho Event post: before 5.9.7 — fixed in 5.9.7
How to fix
Upgrade to a fixed version: Bastien Ho Event post 5.9.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3182549/
- https://wordpress.org/plugins/event-post/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f3ae1c32-18a7-4109-a7ea-dfd18fa3a8e2?source=cve
Get alerted when CVE-2024-10186 or the next vulnerability affects your stack