What’s Vulnerable › Vulnerabilities
CVE-2024-10187: myCred <= 2.7.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via mycred_link Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The myCred – Loyalty Points and Rewards plugin for WordPress and WooCommerce – Give Points, Ranks, Badges, Cashback, WooCommerce rewards, and WooCommerce credits for Gamification plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's mycred_link shortcode in all versions up to, and including, 2.7.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- saadiqbal Points Management System For Gamification, Ranks, Badges, and Loyalty Rewards Program – myCred: before 2.7.5 — fixed in 2.7.5
How to fix
Upgrade to a fixed version: saadiqbal Points Management System For Gamification, Ranks, Badges, and Loyalty Rewards Program – myCred 2.7.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3183178/
- https://wordpress.org/plugins/mycred/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/23a081d4-443d-4b3b-8c89-9eb0e23c961e?source=cve
Get alerted when CVE-2024-10187 or the next vulnerability affects your stack