What’s Vulnerable › Vulnerabilities
CVE-2024-10188: Denial of Service in BerriAI/litellm
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-400
Description
A vulnerability in BerriAI/litellm, as of commit 26c03c9, allows unauthenticated users to cause a Denial of Service (DoS) by exploiting the use of ast.literal_eval to parse user input. This function is not safe and is prone to DoS attacks, which can crash the litellm Python server.
Affected products
- BerriAI litellm: before 1.53.1 — fixed in 1.53.1
How to fix
Upgrade to a fixed version: BerriAI litellm 1.53.1. Check the vendor advisory for mitigations.
References
- https://github.com/berriai/litellm/commit/21156ff5d0d84a7dd93f951ca033275c77e4f73c
- https://huntr.com/bounties/96a32812-213c-4819-ba4e-36143d35e95b
Get alerted when CVE-2024-10188 or the next vulnerability affects your stack