What’s Vulnerable › Vulnerabilities
CVE-2024-10189: Anchor Episodes Index (Spotify for Podcasters) <= 2.1.10 - Authenticated (Contributor+) Stored Cross-Site Scripting via anchor_episodes Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The Anchor Episodes Index (Spotify for Podcasters) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's anchor_episodes shortcode in all versions up to, and including, 2.1.10 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- jeswd Anchor Episodes Index (Spotify for Podcasters): before 2.1.11 — fixed in 2.1.11
How to fix
Upgrade to a fixed version: jeswd Anchor Episodes Index (Spotify for Podcasters) 2.1.11. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3171752/
- https://wordpress.org/plugins/anchor-episodes-index/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8c8e37f8-708e-41d5-a6b8-3ba587437532?source=cve
Get alerted when CVE-2024-10189 or the next vulnerability affects your stack