What’s Vulnerable › Vulnerabilities
CVE-2024-10215: WPBookit <= 1.6.4 - Unauthenticated Arbitrary User Password Change
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-09 · updated 2026-06-17
- Weakness: CWE-639
Description
The WPBookit plugin for WordPress is vulnerable to Arbitrary User Password Change in versions up to, and including, 1.6.4. This is due to the plugin providing user-controlled access to objects, letting a user bypass authorization and access system resources. This makes it possible for unauthenticated attackers to change user passwords and potentially take over administrator accounts.
Affected products
- iqonicdesign WPBookit: before 1.6.6 — fixed in 1.6.6
How to fix
Upgrade to a fixed version: iqonicdesign WPBookit 1.6.6. Check the vendor advisory for mitigations.
References
- https://documentation.iqonic.design/wpbookit/versions/change-log
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2d23a2b9-8476-4564-a5de-5e6cfc38ce68?source=cve
Get alerted when CVE-2024-10215 or the next vulnerability affects your stack