What’s Vulnerable › Vulnerabilities

CVE-2024-10219: Incorrect Authorization in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 15.6 before 18.0.6, 18.1 before 18.1.4, and 18.2 before 18.2.2 that under certain conditions could have allowed authenticated users to bypass access controls and download private artifacts by accessing specific API endpoints.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.0.6, 18.1.4, 18.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-10219 or the next vulnerability affects your stack