What’s Vulnerable › Vulnerabilities
CVE-2024-10224
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-19 · updated 2026-06-17
- Weakness: CWE-78
Description
Qualys discovered that if unsanitized input was used with the library Modules::ScanDeps, before version 1.36 a local attacker could possibly execute arbitrary shell commands by open()ing a "pesky pipe" (such as passing "commands|" as a filename) or by passing arbitrary strings to eval().
Affected products
- Debian Linux: 11.0
- Rschupp Modules::Scandeps: before 1.36 — fixed in 1.36
How to fix
Upgrade to a fixed version: Rschupp Modules::Scandeps 1.36. Check the vendor advisory for mitigations.
References
- https://github.com/rschupp/Module-ScanDeps/security/advisories/GHSA-g597-359q-v529
- https://www.cve.org/CVERecord?id=CVE-2024-10224
- https://www.qualys.com/2024/11/19/needrestart/needrestart.txt
- http://seclists.org/fulldisclosure/2024/Nov/15
- http://seclists.org/fulldisclosure/2024/Nov/17
- https://lists.debian.org/debian-lts-announce/2024/11/msg00015.html
- https://www.openwall.com/lists/oss-security/2024/11/19/1
Get alerted when CVE-2024-10224 or the next vulnerability affects your stack