What’s Vulnerable › Vulnerabilities
CVE-2024-10228: Vagrant VMWare Utility installation files vulnerable to modification by unprivileged user
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-29 · updated 2026-06-17
- Weakness: CWE-732
Description
The Vagrant VMWare Utility Windows installer targeted a custom location with a non-protected path that could be modified by an unprivileged user, introducing potential for unauthorized file system writes. This vulnerability, CVE-2024-10228, was fixed in Vagrant VMWare Utility 1.0.23
Affected products
- HashiCorp Vagrant Vmware Utility: before 1.0.23 — fixed in 1.0.23
How to fix
Upgrade to a fixed version: HashiCorp Vagrant Vmware Utility 1.0.23. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10228 or the next vulnerability affects your stack