What’s Vulnerable › Vulnerabilities
CVE-2024-10268: MP3 Audio Player – Music Player, Podcast Player & Radio by Sonaar <= 5.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via sonaar_audioplayer Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-19 · updated 2026-06-17
- Weakness: CWE-79
Description
The MP3 Audio Player – Music Player, Podcast Player & Radio by Sonaar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's sonaar_audioplayer shortcode in all versions up to, and including, 5.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- sonaar MP3 Audio Player – Music Player, Podcast Player & Radio by Sonaar: before 5.9 — fixed in 5.9
How to fix
Upgrade to a fixed version: sonaar MP3 Audio Player – Music Player, Podcast Player & Radio by Sonaar 5.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3188034/
- https://wordpress.org/plugins/mp3-music-player-by-sonaar/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/861d0218-0f0f-4299-a0ff-854832348457?source=cve
Get alerted when CVE-2024-10268 or the next vulnerability affects your stack