What’s Vulnerable › Vulnerabilities
CVE-2024-10269: Easy SVG Support <= 3.7 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The Easy SVG Support plugin for WordPress is vulnerable to Stored Cross-Site Scripting via REST API SVG File uploads in all versions up to, and including, 3.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
Affected products
- benjamin_zekavica Easy SVG Support: before 3.8 — fixed in 3.8
How to fix
Upgrade to a fixed version: benjamin_zekavica Easy SVG Support 3.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3181757/
- https://wordpress.org/plugins/easy-svg/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5fbc0866-1e9d-457a-8ef3-fb046c89c1dd?source=cve
Get alerted when CVE-2024-10269 or the next vulnerability affects your stack