What’s Vulnerable › Vulnerabilities
CVE-2024-10272: Broken Access Control in lunary-ai/lunary
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-862
Description
lunary-ai/lunary is vulnerable to broken access control in the latest version. An attacker can view the content of any dataset without any kind of authorization by sending a GET request to the /v1/datasets endpoint without a valid authorization token.
Affected products
- lunary-ai/lunary: before 1.4.9 — fixed in 1.4.9
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.4.9. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/35dd4af0001a54ccb14276a1546eb977f82c0c5e
- https://huntr.com/bounties/3de48a54-b5c9-40a1-b794-d59c36d58fb6
- https://huntr.com/bounties/3de48a54-b5c9-40a1-b794-d59c36d58fb6
Get alerted when CVE-2024-10272 or the next vulnerability affects your stack