What’s Vulnerable › Vulnerabilities
CVE-2024-10274: Improper Authorization in lunary-ai/lunary
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-862
Description
An improper authorization vulnerability exists in lunary-ai/lunary version 1.5.5. The /users/me/org endpoint lacks adequate access control mechanisms, allowing unauthorized users to access sensitive information about all team members in the current organization. This vulnerability can lead to the disclosure of sensitive information such as names, roles, or emails to users without sufficient privileges, resulting in privacy violations and potential reconnaissance for targeted attacks.
Affected products
- lunary-ai/lunary: before 1.5.7 — fixed in 1.5.7
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.5.7. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/8ba1b8ba2c2c30b1cec30eb5777c1fda670cbbfc
- https://huntr.com/bounties/506459c1-da60-45c5-a10d-8bd540a4b4c1
Get alerted when CVE-2024-10274 or the next vulnerability affects your stack