What’s Vulnerable › Vulnerabilities
CVE-2024-10275: Improper Role Modification by Admins for Billing Permissions in lunary-ai/lunary
- Severity: high (CVSS 7.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-863
Description
In version 1.5.5 of lunary-ai/lunary, a vulnerability exists where admins, who do not have direct permissions to access billing resources, can change the permissions of existing users to include billing permissions. This can lead to a privilege escalation scenario where an administrator can manage billing, effectively bypassing the intended role-based access control. Only users with the 'owner' role should be allowed to invite members with billing permissions. This flaw allows admins to circumvent those restrictions, gaining unauthorized access and control over billing information, posing a risk to the organization’s financial resources.
Affected products
- lunary-ai/lunary: before 1.5.7 — fixed in 1.5.7
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.5.7. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/8ba1b8ba2c2c30b1cec30eb5777c1fda670cbbfc
- https://huntr.com/bounties/863ee34b-c4c6-4325-bf7a-82a7feebf88f
Get alerted when CVE-2024-10275 or the next vulnerability affects your stack