What’s Vulnerable › Vulnerabilities
CVE-2024-10284: CE21 Suite <= 2.2.0 - Authentication Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-09 · updated 2026-06-17
- Weakness: CWE-288
Description
The CE21 Suite plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 2.2.0. This is due to hardcoded encryption key in the 'ce21_authentication_phrase' function. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the email.
Affected products
- ce21com CE21 Suite: before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: ce21com CE21 Suite 2.2.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ce21-suite/trunk/single-sign-on-ce21.php?rev=3097700#L242
- https://plugins.trac.wordpress.org/changeset/3205463/ce21-suite#file3
- https://www.wordfence.com/threat-intel/vulnerabilities/id/45d66743-300e-480d-98b8-99dc30b6e786?source=cve
Get alerted when CVE-2024-10284 or the next vulnerability affects your stack