What’s Vulnerable › Vulnerabilities
CVE-2024-10312: Exclusive Addons for Elementor <= 2.7.4 - Authenticated (Contributor+) Sensitive Information Exposure via Elementor Templates
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-29 · updated 2026-06-17
- Weakness: CWE-200
Description
The Exclusive Addons for Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.7.4 via the render function in elements/tabs/tabs.php. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive private, pending, and draft template data.
Affected products
- timstrifler Exclusive Addons for Elementor: before 2.7.5 — fixed in 2.7.5
How to fix
Upgrade to a fixed version: timstrifler Exclusive Addons for Elementor 2.7.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3175285/exclusive-addons-for-elementor
- https://www.wordfence.com/threat-intel/vulnerabilities/id/dc931943-13f3-4ab1-b70f-c234253ca269?source=cve
Get alerted when CVE-2024-10312 or the next vulnerability affects your stack