What’s Vulnerable › Vulnerabilities
CVE-2024-10324: RomethemeKit For Elementor <= 1.5.2 - Authenticated (Contributor+) Sensitive Information Exposure via Elementor Templates
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-24 · updated 2026-06-17
- Weakness: CWE-1230
Description
The RomethemeKit For Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.5.2 via the register_controls function in widgets/offcanvas-rometheme.php. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive private, pending, and draft template data.
Affected products
- RomethemeKit For Elementor: before 1.5.3 — fixed in 1.5.3
How to fix
Upgrade to a fixed version: RomethemeKit For Elementor 1.5.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3220079/rometheme-for-elementor
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cd726b20-75c9-408e-86fc-061db591a9db?source=cve
Get alerted when CVE-2024-10324 or the next vulnerability affects your stack