What’s Vulnerable › Vulnerabilities
CVE-2024-10326: RomethemeKit For Elementor <= 1.5.3 - Missing Authorization in save_options and reset_widgets
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-08 · updated 2026-06-17
- Weakness: CWE-862
Description
The RomethemeKit For Elementor plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_options and reset_widgets functions in all versions up to, and including, 1.5.3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to modify plugin settings or reset plugin widgets to their default state (all enabled). NOTE: This vulnerability was partially fixed in version 1.5.3.
Affected products
- RomethemeKit For Elementor: before 1.5.4 — fixed in 1.5.4
How to fix
Upgrade to a fixed version: RomethemeKit For Elementor 1.5.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3220079/rometheme-for-elementor
- https://plugins.trac.wordpress.org/changeset/3231792/rometheme-for-elementor
- https://www.wordfence.com/threat-intel/vulnerabilities/id/230b3f2f-44cf-46eb-8e6a-3c52f2ea2fb9?source=cve
Get alerted when CVE-2024-10326 or the next vulnerability affects your stack