What’s Vulnerable › Vulnerabilities
CVE-2024-10329: Ultimate Bootstrap Elements for Elementor <= 1.4.6 - Authenticated (Contributor+) Sensitive Information Exposure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-05 · updated 2026-06-17
- Weakness: CWE-200
Description
The Ultimate Bootstrap Elements for Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.4.6 via the 'ube_get_page_templates' function. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive data including the contents of templates that are private.
Affected products
- g5theme Ultimate Bootstrap Elements for Elementor: before 1.4.7 — fixed in 1.4.7
How to fix
Upgrade to a fixed version: g5theme Ultimate Bootstrap Elements for Elementor 1.4.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ultimate-bootstrap-elements-for-elementor/trunk/inc/functions/core.php#L239
- https://plugins.trac.wordpress.org/changeset/3176562/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3af83ec2-9ebb-4cca-8523-8fe9b1517825?source=cve
Get alerted when CVE-2024-10329 or the next vulnerability affects your stack