What’s Vulnerable › Vulnerabilities
CVE-2024-10352: Magical Addons For Elementor <= 1.2.4 - Authenticated (Contributor+) Sensitive Information Exposure via Elementor Template
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-09 · updated 2026-06-17
- Weakness: CWE-200
Description
The Magical Addons For Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.2.4 via the get_content_type function in includes/widgets/content-reveal.php. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive private, pending, and draft template data.
Affected products
- nalam-1 Magical Addons For Elementor ( Header Footer Builder, Free Elementor Widgets, Elementor Templates Library ): before 1.2.5 — fixed in 1.2.5
How to fix
Upgrade to a fixed version: nalam-1 Magical Addons For Elementor ( Header Footer Builder, Free Elementor Widgets, Elementor Templates Library ) 1.2.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3182827/magical-addons-for-elementor
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8aa2ba7f-c33d-4e80-b1cf-2d7b2a497f04?source=cve
Get alerted when CVE-2024-10352 or the next vulnerability affects your stack