What’s Vulnerable › Vulnerabilities
CVE-2024-10383: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab VSCode Fork
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-07 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue has been discovered in the gitlab-web-ide-vscode-fork component distributed over CDN affecting all versions prior to 1.89.1-1.0.0-dev-20241118094343and used by all versions of GitLab CE/EE starting from 15.11 prior to 17.3 and which also temporarily affected versions 17.4, 17.5 and 17.6, where a XSS attack was possible when loading .ipynb files in the web IDE
Affected products
- GitLab: from 15.11.0 before 17.3.0; 17.4.0, 17.5.0, 17.6.0 — fixed in 17.3.0
How to fix
Upgrade to a fixed version: GitLab 17.3.0. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab/-/issues/500785
- https://hackerone.com/reports/2765778
- https://gitlab.com/gitlab-org/gitlab/-/issues/500785
Get alerted when CVE-2024-10383 or the next vulnerability affects your stack