What’s Vulnerable › Vulnerabilities
CVE-2024-10385: Stored XSS in DirectAdmin Evo Skin
- Severity: high (CVSS 8.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Ticket management system in DirectAdmin Evolution Skin is vulnerable to XSS (Cross-site Scripting), which allows a low-privileged user to inject and store malicious JavaScript code. If an admin views the ticket, the script might perform actions with their privileges, including command execution. This issue has been fixed in version 1.668 of DirectAdmin Evolution Skin.
Affected products
- DirectAdmin Evolution Skin: before 1.668 — fixed in 1.668
How to fix
Upgrade to a fixed version: DirectAdmin Evolution Skin 1.668. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10385 or the next vulnerability affects your stack