What’s Vulnerable › Vulnerabilities
CVE-2024-10402: Forminator Forms – Contact Form, Payment Form & Custom Form Builder <= 1.35.1 - Missing Authorization to Authenticated (Contributor+) Form Update and Creation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-26 · updated 2026-06-17
- Weakness: CWE-862
Description
The Forminator Forms – Contact Form, Payment Form & Custom Form Builder plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on a function in all versions up to, and including, 1.35.1. This makes it possible for authenticated attackers, with Contributor-level access and above, and permissions granted by an Administrator, to create new or edit existing forms, including updating the default registration role to Administrator on User Registration forms.
Affected products
- wpmudev Forminator Forms – Contact Form, Payment Form & Custom Form Builder: before 1.36.0 — fixed in 1.36.0
How to fix
Upgrade to a fixed version: wpmudev Forminator Forms – Contact Form, Payment Form & Custom Form Builder 1.36.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3169243/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/be1d9d2b-cbdf-4d62-85fe-2616eaf02848?source=cve
Get alerted when CVE-2024-10402 or the next vulnerability affects your stack