What’s Vulnerable › Vulnerabilities
CVE-2024-10444
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-19 · updated 2026-06-17
- Weakness: CWE-295
Description
Improper certificate validation vulnerability in the LDAP utilities in Synology DiskStation Manager (DSM) before 7.1.1-42962-8, 7.2.1-69057-7 and 7.2.2-72806-3 allows man-in-the-middle attackers to hijack the authentication of administrators via unspecified vectors.
Affected products
- Synology DiskStation Manager: from 7.1 before 7.1.1-42962-8; from 7.2.1-69057 before 7.2.1-69057-7; from 7.2.2 before 7.2.2-72806-3 — fixed in 7.1.1-42962-8, 7.2.1-69057-7, 7.2.2-72806-3
How to fix
Upgrade to a fixed version: Synology DiskStation Manager 7.1.1-42962-8, 7.2.1-69057-7, 7.2.2-72806-3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10444 or the next vulnerability affects your stack