What’s Vulnerable › Vulnerabilities
CVE-2024-10470: WPLMS Learning Management System for WordPress <= 4.962 - Unauthenticated Arbitrary File Read and Deletion
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 34.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-09 · updated 2026-06-17
- Weakness: CWE-22
Description
The WPLMS Learning Management System for WordPress, WordPress LMS theme for WordPress is vulnerable to arbitrary file read and deletion due to insufficient file path validation and permissions checks in the readfile and unlink functions in all versions up to, and including, 4.962. This makes it possible for unauthenticated attackers to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php). The theme is vulnerable even when it is not activated.
Affected products
- VibeThemes Wordpress Learning Management System: before 4.963 — fixed in 4.963
How to fix
Upgrade to a fixed version: VibeThemes Wordpress Learning Management System 4.963. Check the vendor advisory for mitigations.
References
- https://themeforest.net/item/wplms-learning-management-system/6780226
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1932c9b4-2fea-40f8-9748-09ded8143c11?source=cve
Get alerted when CVE-2024-10470 or the next vulnerability affects your stack