What’s Vulnerable › Vulnerabilities
CVE-2024-10471: Everest Forms < 3.0.4.2 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The Everest Forms WordPress plugin before 3.0.4.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- wpeverest Everest Forms – Contact Form, Payment Form, Quiz, Survey & Custom Form Builder: before 3.0.4.2 — fixed in 3.0.4.2
How to fix
Upgrade to a fixed version: wpeverest Everest Forms – Contact Form, Payment Form, Quiz, Survey & Custom Form Builder 3.0.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10471 or the next vulnerability affects your stack