What’s Vulnerable › Vulnerabilities
CVE-2024-10499: AI-Engine < 2.6.5 - Admin+ SQLi
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-89
Description
The AI Engine WordPress plugin before 2.6.5 does not sanitize and escape a parameter from one of its RESP API endpoint before using it in a SQL statement, allowing admins to perform SQL injection attacks
Affected products
- AI Engine: before 2.6.5 — fixed in 2.6.5
How to fix
Upgrade to a fixed version: AI Engine 2.6.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10499 or the next vulnerability affects your stack