What’s Vulnerable › Vulnerabilities
CVE-2024-10504: ARForms Builder < 1.7.1 - Unauthenticated Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The Contact Form, Survey, Quiz & Popup Form Builder WordPress plugin before 1.7.1 does not sanitise and escape some parameters when outputting them in the page, which could allow unauthenticated users to perform Cross-Site Scripting attacks.
Affected products
- reputeinfosystems ARForms: before 1.7.1 — fixed in 1.7.1
How to fix
Upgrade to a fixed version: reputeinfosystems ARForms 1.7.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9a22df11-0e24-4248-a8f3-da8f23ccb313/
- https://wpscan.com/vulnerability/9a22df11-0e24-4248-a8f3-da8f23ccb313/
Get alerted when CVE-2024-10504 or the next vulnerability affects your stack