What’s Vulnerable › Vulnerabilities
CVE-2024-10515: SEO Plugin by Squirrly SEO < 12.3.21 - Editor+ Stored XSS
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-20 · updated 2026-06-17
- Weakness: CWE-79
Description
In the process of testing the SEO Plugin by Squirrly SEO WordPress plugin before 12.3.21, a vulnerability was found that allows you to implement Stored XSS on behalf of the editor by embedding malicious script, which entails account takeover backdoor
Affected products
- SEO Squirrly SEO Plugin by Squirrly SEO: before 12.3.21 — fixed in 12.3.21
How to fix
Upgrade to a fixed version: SEO Squirrly SEO Plugin by Squirrly SEO 12.3.21. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-10515 or the next vulnerability affects your stack