What’s Vulnerable › Vulnerabilities
CVE-2024-10519: Wishlist for WooCommerce: Multi Wishlists Per Customer PRO 3.0.8 - 3.1.2 - Reflected Cross-Site Scripting via wtab Parameter
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The Wishlist for WooCommerce: Multi Wishlists Per Customer PRO plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'wtab' parameter in versions 3.0.8 to 3.1.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Note: Only WordPress installations with versions of PHP <=7.4 are affected by this vulnerability.
Affected products
- WPFactory Wishlist for WooCommerce: from 3.0.8 before 3.1.3 — fixed in 3.1.3
How to fix
Upgrade to a fixed version: WPFactory Wishlist for WooCommerce 3.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/wpcodefactory/wish-list-for-woocommerce/blame/master/templates/wish-list.php#L214
- https://github.com/wpcodefactory/wish-list-for-woocommerce/blob/fafa2319a8907d3260a89a2a6b4fa9ea6602c7db/templates/wish-list.php#L94
- https://plugins.trac.wordpress.org/browser/wish-list-for-woocommerce/trunk/templates/wish-list.php#L215
- https://plugins.trac.wordpress.org/changeset/3189775/
- https://wordpress.org/plugins/wish-list-for-woocommerce/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/eb14896f-7f0e-4168-8a2d-309bbaddbedc?source=cve
Get alerted when CVE-2024-10519 or the next vulnerability affects your stack