What’s Vulnerable › Vulnerabilities
CVE-2024-10521: WordPress Contact Forms by Cimatti <= 1.9.2 - Cross-Site Request Forgery via process_bulk_action Function
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-27 · updated 2026-06-17
- Weakness: CWE-352
Description
The WordPress Contact Forms by Cimatti plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.9.2. This is due to missing or incorrect nonce validation on the process_bulk_action function. This makes it possible for unauthenticated attackers to delete forms via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- cimatti Contact Forms by Cimatti: before 1.9.3 — fixed in 1.9.3
How to fix
Upgrade to a fixed version: cimatti Contact Forms by Cimatti 1.9.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/contact-forms/trunk/accua-forms-list-page.php#L154
- https://plugins.trac.wordpress.org/browser/contact-forms/trunk/accua-forms-submissions-page.php#L348
- https://plugins.trac.wordpress.org/changeset/3196728/
- https://wordpress.org/plugins/contact-forms/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f86e8ccb-a865-4da5-9250-dd715b8cdbe7?source=cve
Get alerted when CVE-2024-10521 or the next vulnerability affects your stack