What’s Vulnerable › Vulnerabilities
CVE-2024-10524: GNU Wget is vulnerable to an SSRF attack when accessing partially-user-controlled shorthand URLs
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-19 · updated 2026-06-17
- Weakness: CWE-918
Description
Applications that use Wget to access a remote resource using shorthand URLs and pass arbitrary user credentials in the URL are vulnerable. In these cases attackers can enter crafted credentials which will cause Wget to access an arbitrary host.
Affected products
- gnuwget wget: before 1.25.0 — fixed in 1.25.0
How to fix
Upgrade to a fixed version: gnuwget wget 1.25.0. Check the vendor advisory for mitigations.
References
- https://git.savannah.gnu.org/cgit/wget.git/commit/?id=c419542d956a2607bbce5df64b9d378a8588d778
- https://jfrog.com/blog/cve-2024-10524-wget-zero-day-vulnerability/
- https://seclists.org/oss-sec/2024/q4/107
- http://www.openwall.com/lists/oss-security/2024/11/18/6
- https://security.netapp.com/advisory/ntap-20250321-0007/
Get alerted when CVE-2024-10524 or the next vulnerability affects your stack